728x90
유효한 팰린드롬
▣ 설명
앞에서 읽을 때나 뒤에서 읽을 때나 같은 문자열을 팰린드롬이라고 합니다. 문자열이 입력되면 해당 문자열이 팰린드롬이면 "YES", 아니면 “NO"를 출력하는 프로그램을 작성하세요. 단 회문을 검사할 때 알파벳만 가지고 회문을 검사하며, 대소문자를 구분하지 않습니다. 알파벳 이외의 문자들의 무시합니다.
▣ 입력설명
첫 줄에 길이 100을 넘지 않는 공백이 없는 문자열이 주어집니다.
▣ 출력설명
첫 번째 줄에 팰린드롬인지의 결과를 YES 또는 NO로 출력합니다.
▣ 입력예제 1
found7, time: study; Yduts; emit, 7Dnuof
▣ 출력예제 1
YES
📌 풀이
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
public class Main {
public static void main(String[] args) throws IOException {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
String str = br.readLine();
String result = solution(str);
System.out.println(result);
}
static String solution(String str) {
str = str.toUpperCase()
.replaceAll("[^A-Z]", "");
String temp = new StringBuilder(str)
.reverse()
.toString();
if(str.equals(temp)) {
return "YES";
}
return "NO";
}
}
String#replaceAll() 메서드를 통해 정규식으로 대문자가 아닌 모든 것들 지웠다.
728x90
'[알고리즘] > 자바 알고리즘 공부' 카테고리의 다른 글
[알고리즘 공부] 등수 구하기 (0) | 2022.04.15 |
---|---|
[알고리즘 공부] 점수 계산 (0) | 2022.04.15 |
[알고리즘 공부] 소수 구하기 (에라토스테네스 체) (0) | 2022.04.14 |
[알고리즘 공부] 회문 문자열 (0) | 2022.04.08 |